Frequent crashes on iPad Pro


Home Forums RAW Power for iOS General Discussion Frequent crashes on iPad Pro

Tagged: ,

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #90466
    thewildrover
    Participant

    Hi Nik,

    I’ve been trying out Raw Power alongside Photos for the last week or so now, among other apps too, but RP is my favourite so far.

    However, it is crashing/quitting quite frequently (often enough that it spoils the workflow). It seems to happen at a couple of notable points. First it happens after a batch process, select a batch of images in an album, apply Auto Enhance, then click ‘Allow’. It’s usually completed the process before the crash, so I can re-open and carry on editing.

    Other times it crashes while editing, doesn’t seem to be related to any particular adjustment, and is rather random, can happen after a handful of images, or a few dozen, but usually before I’ve finished working though an album. I only usually tweak things like Boost, highlights and shadows, exposure etc., sometimes a bit of cropping.

    Seems OK for general browsing.

    I’ve been using Pixelmator in a similar fashion, and seen no issues at all with that, and my library is very fresh (haven’t even finished uploading everything yet).

    New iPad Pro 12.9” 512GB, recently installed Raw Power.

    Cheers

    Andy

    #91069
    Nik Bhatt
    Keymaster

    Hi,

    I’m sorry the app is crashing on you so much. iOS is a challenging platform to write for – if an app uses the tiniest amount more memory than the system can support, the app is instantly terminated by the OS. I have made significant improvements to Auto Enhance for the next release (3.1). It uses much less memory and is much faster as well. That should help a lot with the first crash.

    As far as the other one, it’s hard to tell right now. If you are interested in beta testing the 3.1 release, please email support@gentlemencoders.com and I can put you on the list. Maybe we can figure out the second one too.

    #91383
    thewildrover
    Participant

    Hi Nik,

    Thanks for the reply. OK, I understand what’s going on a bit more, so no worries.

    I think I’ve sorted the second issue, I also started seeing all sorts of weird things happening, such as multiple ‘Revert’ boxes not related to the image I was working on. So I ran the Reindex option, and that seems to be resolved now, as is the crash when editing.

    As far as the batch process crash, would it help to run it on smaller sets of images, My albums vary from a handful to many hundreds. Would working on, say, a max of 100 at a time be better?

    Cheers, and thank you for an otherwise great photo editor (I also have the Mac version).

    Andy

    #93173
    Nik Bhatt
    Keymaster

    Hi Andy,

    I’m glad the re-index helped you. I have not heard about multiple revert boxes appearing – that’s a first…

    Yes, I think running smaller batches will probably help, especially on iOS.

    –Nik

    #93557
    thewildrover
    Participant

    Yes it does seem to have helped for sure.

    My apologies, I did mean the ‘Modify’ dialogue, although I think it did happen with the Revert too. If I clicked on the ‘Done’ button, I sometimes got the Modify box, or Revert box, pop up twice, and then put me back into Edit mode, after I’d clicked them.

    I’ve tried an album with 106 images, and that crashed, although I’ve also done some with over 300 and it’s been fine. These are all 16MP NEF images. So not by any means a consistent issue.

    Cheers

    Andy.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.